Author Archives: yangtingkun

ORA-600(kgh_heap_sizes:ds)和ORA-600(kghGetHpSz1)错误

在客户10203数据库中发现多个ORA-600和ORA-7445错误。 详细错误信息如下: Tue DEC 27 11:13:55 2011 Errors IN file /oracle/admin/htzback/udump/htzback_ora_22492.trc: ORA-00600: 内部错误代码, 参数: [kgh_heap_sizes:ds], [0x2B902679E3F8], [], [], [], [], [], [] ORA-00600: 内部错误代码, 参数: [kghGetHpSz1], [0x2B902679F868], [], [], [], [], [], [] ORA-00600: 内部错误代码, 参数: [kghstack_free2], [], [], [], … Continue reading →

Posted in BUG | Tagged , , , , , , , | Leave a comment

告警日志出现分布式事务缺少DTP服务信息

客户的RAC环境中出现这个告警信息。 详细信息如下: Thu DEC 23 09:23:15 2011 Running Distributed Transactions IN RAC WITHOUT DTP service.Thu Dec 23 09:23:15 2011 Running Distributed Transactions in RAC without DTP service. 查询MOS发现,对于10.2版本的数据库,如果连接RAC环境,且执行分布式事务,那么应该启用DTP服务。 从告警日志的其他部分,可以发现数据库确实使用了分布式事务,因为已经出现了分布式事务的错误: Tue DEC 23 09:25:14 2011 DISTRIB TRAN 44444444.99A137F01FBF14AACDCA8A9D3C8FED5800000000 IS LOCAL tran … Continue reading →

Posted in ORACLE | Tagged , , , , | Leave a comment

由于DBTIME时间太短导致AWR出现告警信息

一个客户的RAC环境的AWR,由于DB TIME时间太短,导致出现告警信息。 这是一个10.2.0.5 RAC for Linux X86环境,由于全部应用都连接到一个节点上,因此另一个节点出现这个告警。 在AWR报告中的正文开始之前的部分,有下面的告警信息: WARNING: Since the DB Time is less than one second, there was minimal foreground activity in the snapshot period. Some of the percentage values will be invalid. 虽然以前也碰到过节点很闲的情况,但是真没有碰到过负载这么轻的系统: Snap Id Snap Time … Continue reading →

Posted in ORACLE | Tagged , , | Leave a comment

数据泵导出出现ORA-31617错误

客户的Oracle10204 RAC FOR Hp数据库执行EXPDP并行导出时出现了这个错误信息。 导出报错如下: Export: Release 10.2.0.4.0 – 64bit Production ON Thursday, 12 January, 2012 6:10:00 Copyright (c) 2003, 2007, Oracle. ALL rights reserved. Connected TO: Oracle DATABASE 10g Enterprise Edition Release 10.2.0.4.0 – 64bit Production WITH the Partitioning, … Continue reading →

Posted in ORACLE | Tagged , , , , | 1 Comment

ORA-600(13013)错误

客户环境中出现ORA-600(13013)错误。 错误信息如下: Mon DEC 26 23:13:00 2011 Errors IN file /oracle/admin/htzback/udump/htzback_ora_32522.trc: ORA-00600: 内部错误代码, 参数: [13013], [5001], [52828], [625368235], [67], [629556358], [17], []Mon Dec 26 23:13:00 2011 Errors in file /oracle/admin/htzback/udump/htzback_ora_32522.trc: ORA-00600: 内部错误代码, 参数: [13013], [5001], [52828], [625368235], [67], [629556358], [17], … Continue reading →

Posted in BUG | Tagged , , | Leave a comment

DATE类型截取到天的效率

在ITPUB上看了一个帖子,根据日期类型对每天的记录进行GROUP BY,帖子的地址如下:http://www.itpub.net/thread-1564295-1-1.html 这种包含全表扫描执行GROUP BY的语句是否还有优化的余地吗,事实上确实还有,因为对于处理日期类型,TO_CHAR并没有TRUNC高效。 下面看一个简单的例子: SQL> CREATE TABLE T_DATE AS 2 SELECT ROWNUM ID, CREATED 3 FROM DBA_OBJECTS A, (SELECT 1 FROM DUAL CONNECT BY ROWNUM < 100) 4 WHERE ROWNUM <= 1000000; TABLE created. SQL> SELECT COUNT(*) FROM T_DATE; … Continue reading →

Posted in ORACLE | Tagged , , | Leave a comment

ORA-600(16608)错误

客户10.2.0.4环境出现ORA-600(16608)错误。 详细错误信息如下: Sun DEC 19 11:17:41 2010 Errors IN file /u01/app/oracle/admin/orcl/bdump/orcl_j005_5937.trc: ORA-00600: internal error code, arguments: [16608], [2], [3], [0x8000002C4FA00DC0], [], [], [], []Sun Dec 19 11:17:41 2010 Errors in file /u01/app/oracle/admin/orcl/bdump/orcl_j005_5937.trc: ORA-00600: internal error code, arguments: [16608], [2], [3], … Continue reading →

Posted in BUG | Tagged , , , , | Leave a comment

ORA-600(ksmals)错误

客户数据库出现ORA-600(ksmals)错误。 错误信息为: Tue Nov 22 11:39:02 2011 Errors in file /oracle9/app/admin/db/udump/db1_ora_2319324.trc: ORA-00600: internal error code, arguments: [ksmals], [sql txt in kkslod], [], [], [], [], [], [] 查询这个错误,确认是Oracle的bug,详细描述可以参考:ORA-600 [ksmals], [sql txt in kkslod], [] Selecting Against x$kgllk [ID 550066.1]。这个问题影响9.2到11.1之间的所有版本。当查询x$kgllk内部表,或基于这个内部表的视图时,就可能引发这个问题。 从对应的trace文件中可以看到,导致错误的SQL在查询V$OPEN_CURSOR和V$SQL视图: … Continue reading →

Posted in BUG | Tagged , , , , , | Leave a comment

客户数据库升级后出现ORA-30004错误

帮客户将数据库从11.2.0.1升级到11.2.0.3后,数据库运行正常,不过随后出现了ORA-30004错误。 这个错误以前还真没有碰到过,检查后发现感觉问题似乎不一定和升级有关系: ORA-30004: WHEN USING SYS_CONNECT_BY_PATH FUNCTION, cannot have separator AS part OF COLUMN VALUE Cause: A COLUMN VALUE contained the string that the SYS_CONNECT_BY_PATH FUNCTION was TO USE TO separate COLUMN VALUES. Action: Specify another separator FOR the SYS_CONNECT_BY_PATH … Continue reading →

Posted in NEWS | Tagged , , | Leave a comment

ORA-600(ttcgcshnd-2)错误

客户数据库出现这个错误信息。 以前碰到过一个很老的bug,错误信息和当前十分接近,为ttcgcshnd-1,导致问题的原因是较低的jdbc驱动所致,详细情况可以参考:http://yangtingkun.itpub.net/post/468/461992 当前的问题并不太一样,导致问题的主要原因是用户取消了操作: Mon DEC 5 10:13:50 2011 Errors IN file /oracle9/app/admin/db/udump/db1_ora_1867892.trc: ORA-00600: internal error code, arguments: [ttcgcshnd-2], [0], [], [], [], [], [], [] ORA-01013: USER requested cancel OF CURRENT operation Mon DEC 5 10:13:51 2011 Trace dumping IS … Continue reading →

Posted in BUG | Tagged , , , | Leave a comment