-
Recent Posts
Recent Comments
- yangtingkun on 非空字段空值对查询的影响
- Eric Zong on 非空字段空值对查询的影响
- Kamus on Oracle Ace Director
- 设置全局死锁优先级 | yangtingkun on RAC全局死锁检测时间
- ORA-600(krbounotread_noctx)错误 | yangtingkun on ORA-600(krboReadBitmap_badbitmap)错误
Archives
- December 2020
- February 2019
- December 2018
- November 2018
- October 2018
- July 2018
- June 2018
- May 2018
- July 2016
- July 2013
- June 2013
- November 2012
- October 2012
- September 2012
- August 2012
- July 2012
- June 2012
- May 2012
- April 2012
- March 2012
- February 2012
- January 2012
- December 2011
- November 2011
- October 2011
- September 2011
- August 2011
Categories
Meta
Author Archives: yangtingkun
OPAQUE_TRANSFORM提示的产生
最近经常在AWR中看到带有OPAQUE_TRANSFORM提示的SQL语句,根据分析可以确认执行这个SQL的语句是通过数据库链连接到本地,但是测试时发现,普通的数据库链连接并不会导致这个提示的产生。 于是做了一个简单的例子: -bash-3.2$ sqlplus test/test SQL*Plus: Release 10.2.0.5.0 – Production ON Mon DEC 5 15:05:09 2011 Copyright (c) 1982, 2010, Oracle. ALL Rights Reserved. Connected TO: Oracle DATABASE 11g Enterprise Edition Release 11.2.0.2.0 – Production WITH the Partitioning, OLAP, DATA … Continue reading
索引重建的数据源(二)
对这个问题有了进一步的认识。 索引重建的数据源:http://yangtingkun.itpub.net/post/468/457384 上一篇文章测试的结果认为DDL也是基于CBO的,但是今天发现问题并非如此。Oracle在评估REBUILD索引时并不是根据统计信息,而是根据数据字典中非索引字段的长度: SQL> CREATE TABLE t_rebuild (id NUMBER, flag CHAR(1)); TABLE created. SQL> INSERT INTO t_rebuild SELECT rownum, ‘a’ FROM dba_objects; 15695 ROWS created. SQL> commit; Commit complete. SQL> CREATE INDEX ind_t_rebuild_id ON t_rebuild(id); INDEX created. SQL> EXPLAIN plan … Continue reading
ORA-600(qerfxFetch_01)错误
在客户的9201数据库中,发现这个错误。 错误信息为: Wed Jul 29 09:23:32 2009 Errors IN file /opt/oracle/admin/eomsdb/udump/eomsdb_ora_20242.trc: ORA-00600: internal error code, arguments: [qerfxFetch_01], [], [], [], [], [], [], []Wed Jul 29 09:23:32 2009 Errors in file /opt/oracle/admin/eomsdb/udump/eomsdb_ora_20242.trc: ORA-00600: internal error code, arguments: [qerfxFetch_01], [], [], … Continue reading
11g收集统计信息引发wri$_optstat_histhead_history表的删除
在查看一个客户11.2.0.2的AWR报告时,发现了这个问题。 在SQL ORDER BY ELASPED TIME表中,前两项的结果如下: Elapsed Time (s) Executions %Total %CPU %IO SQL Id SQL Module SQL Text 10,752.79 0 25.86 98.20 7.49 4sff1qphjvbwn SQL*Plus BEGIN dbms_stats.gather_table_… 10,752.75 13 25.86 98.20 7.49 bqn2h1xrmhmht delete from sys.wri$_optstat_h… 可以看到,这2两个语句在花费时间,占用CPU以及IO的百分比上惊人的一致,这绝对不是一个偶然的事件。 第一个SQL是收集表的统计信息,显然这是在SQLPLUS里面执行的操作,其执行次数是0,说明在采样时间内,这个操作还没有完成。根据Elspsed Time估算,这个SQL已经运行了3个小时。 … Continue reading
Oracle VM服务器安装和升级手册
还记得Oracle一推出VM时,我写了一篇文章,不过之后一直没有研究VM。一转眼VM的版本已经到了3.0。 之所以以前一直研究,是因为一直认为数据库和虚拟化的关系并不大。最近几年VMWare发展迅猛,但是跑在上面的数据库却寥寥无几。因此,即使是Oracle自己推出的VM,也一直没有提起兴趣来研究。 不过Oracle的VM有一个最大的优点,就是Oracle在计算License时,承认它自己VM所划分的CPU数,而其他虚拟化软件的CPU划分,严格意义上Oracle是不承认的。 除了License上的好处,各种模板的推出也带来了快速部署的好处。因此打算深入研究一下Oracle的VM,由于以前确实没有安装过,所以这次从安装手册开始看起。 这篇文档的地址:http://docs.oracle.com/cd/E20065_01/doc.30/e18548/toc.htm
Posted in BOOKS
Leave a comment
Oracle高级安全管理手册总结
国内越来越多客户开始注重安全相关的内容了,使得原本一些很少使用的技术,现在开始变得十分的流行。 这篇文档介绍的透明数据加密、网络传输数据加密以及ORACLE Wallet等内容,目前已经有不少客户开始或准备开始应用。而对于绝大部分人而言,这些还是一个很新的内容,真正有经验的人并不多,而随着以后安全性方面的内容越来越受重视,具有安全性知识的DBA会拥有更多的机会。
Posted in BOOKS
Leave a comment
运行脚本diagcollection.pl报错
Oracle的RAC提供了diagcollection.pl脚本,用来收集CLUSTER和数据库的脚本。不过在客户环境中执行这个脚本报错。 详细错误信息为: [root@smsdbrac1 ora_test]# $ORA_CRS_HOME/bin/diagcollection.pl -crshome=$ORA_CRS_HOME -collect Production Copyright 2004, 2005, Oracle. ALL rights reserved Cluster Ready Services (CRS) diagnostic collection tool The following CRS diagnostic archives will be created IN the LOCAL directory. crsData_smsdbrac1.tar.gz -> logs,traces AND cores FROM … Continue reading
告警日志出现skgpspawn failed category 27142错误
客户的数据库告警日志出现skgpspawn failed信息。 详细错误信息如下: Mon Nov 28 07:59:59 2011 skgpspawn failed:category = 27142, depinfo = 11, op = fork, loc = skgpspawn5 skgpspawn failed:category = 27142, depinfo = 11, op = fork, loc = skgpspawn3 skgpspawn failed:category = 27142, depinfo = … Continue reading
Posted in BUG
Tagged 27142, defunct Oracle processes, fork, ORA-27142, skgpspawn failed, skgpspawn3, skgpspawn5, SWAP
Leave a comment
20111127ACOUG活动
今天ACOUG活动的三位嘉宾都是熟人。 第一个主题是smile_lan带来的《数据库访问控制最佳实践》。我们很多客户都需要部署安全相关的解决方案,而在整个解决方案中,技术只是其中一部分,而更多的制度和规则上的设置。而smile_lan带来的GE的案例,可以帮助我们了解全球跨国企业是如何设置数据库访问控制的。特别是OID(Oracle Internet Directory)的应用,在国内还没有碰到过应用的案例,部署OID来解决数据库用户集中访问的方式,绝非一般公司可以采用的方式,一方面需要Oracle数据库广泛的应用到整个企业的日常管理中,另一方面只有大量的数据库、管理员以及维护人员的管理需求还会使得企业采用集中帐号管理的方式。 第二个主题是sundog315带来的《猜想的力量 一次REDO分析的例子》。这个案例其实是数据库嘉年华上EYGLE一个案例的延续,EYGLE当时描述了这个问题,随后sundog315对于这个问题的一个细节问题进行了深入的研究,于是有了今天的这个主题。这个案例中,sundog315描述了他通过多次猜测并验证,最终解决这个问题的步骤。虽然猜测是非常重要的,但是个人认为更重要的是基础知识的积累,否则猜测只能是空中楼台。甚至即使猜到了正确的结果,但是没有知识的积累,也无法验证自己的测试结果。 最后是野花带来的搜索相关的主题,这个主题他在数据库嘉年华上进行演讲,今天的主题显得更加的轻车熟路。其实搜索确实是一门学问,很多新人之所以入门很苦难,就是碰到了自己无法解决的问题后,不知道如何通过搜索来解决问题。事实上,如果可以擅用搜索来解决问题,也证明了一个人的本身的水平的提高。
Posted in NEWS
Leave a comment
ORA-600(5351)错误
在告警日志中发现了ORA-600(5351)错误,同时出现大量的There are 3 memory allocation errors for object-level stat错误。 详细的错误信息为: Tue Jun 22 12:00:09 2010 Thread 1 advanced TO log SEQUENCE 1522 CURRENT log# 3 seq# 1522 mem# 0: /dev/rredo03 There are 6 memory allocation errors FOR object-level stat IN … Continue reading
Posted in BUG
Tagged 5351, memory allocation errors, object-level, ORA-600, shared_pool, _OBJECT_STATISTICS
Leave a comment