-
Recent Posts
Recent Comments
- yangtingkun on 非空字段空值对查询的影响
- Eric Zong on 非空字段空值对查询的影响
- Kamus on Oracle Ace Director
- 设置全局死锁优先级 | yangtingkun on RAC全局死锁检测时间
- ORA-600(krbounotread_noctx)错误 | yangtingkun on ORA-600(krboReadBitmap_badbitmap)错误
Archives
- December 2020
- February 2019
- December 2018
- November 2018
- October 2018
- July 2018
- June 2018
- May 2018
- July 2016
- July 2013
- June 2013
- November 2012
- October 2012
- September 2012
- August 2012
- July 2012
- June 2012
- May 2012
- April 2012
- March 2012
- February 2012
- January 2012
- December 2011
- November 2011
- October 2011
- September 2011
- August 2011
Categories
Meta
Author Archives: yangtingkun
进程日志中出现out of OS kernel IO resources
在检查一个进程的日志时,意外发现这个问题。 错误信息如下: /ora10g/app/admin/dbname/bdump/dbname1_j001_8567.trc Oracle DATABASE 10g Enterprise Edition Release 10.2.0.3.0 – 64bit Production WITH the Partitioning, REAL Application Clusters, OLAP AND DATA Mining options ORACLE_HOME = /ora10g/app/product/10.2.0/dbname System name: HP-UX Node name: dbname1 Release: B.11.23 Version: U Machine: ia64 Instance … Continue reading
ORA-7445(sigsetjmp)错误
客户数据库中出现ORA-7445错误,导致错误的SQL在访问V$ACCESS视图。 错误信息如下: Sun Sep 19 17:15:17 2010 Errors IN file /home/oracle/admin/ARIC/udump/aric_ora_26489.trc: ORA-07445: exception encountered: core dump [SIGSEGV] [Address NOT mapped TO object] [0] [] [] []Sun Sep 19 17:15:17 2010 Errors in file /home/oracle/admin/ARIC/udump/aric_ora_26489.trc: ORA-07445: exception encountered: core dump [SIGSEGV] … Continue reading
11.2数据库登录出现library cache lock等待(二)
客户的11.2.0.2 RAC for Linux X86-64环境的数据库在登录时,发现出现长时间等待。 这一篇描述现象重现过程。 11.2数据库登录出现library cache lock等待(一):https://yangtingkun.net/?p=279 上一篇描述了客户的11.2.0.2 RAC for Linux X86-64环境出现library cache lock的问题,同事回来后想要模拟这个现象,在Windows环境下的11.2.0.1上却没有模拟出来,我也在Windows上的11.2.0.1上尝试了一下,结果没有出现library cache lock等待,但是出现了row cache lock等待事件。 测试步骤很简单,开启三个sqlplus,其中一个设置SET TIME ON,获取时间信息,并不断的已错误的用户名密码尝试连接数据库。另一个会话以正确的用户名和密码连接到数据库,设置SQLPROMPT为SQL2>,以便于和第一个会话区别。最后一个会话以SYS登录数据库,检查会话的等待状态: SQL> SET TIME ON 08:34:41 SQL> CONN TEST/A@192.25.1.100/TEST112 ERROR: ORA-01017: 用户名/口令无效; 登录被拒绝 08:34:42 SQL> CONN TEST/A@192.25.1.100/TEST112 … Continue reading
11.2数据库登录出现library cache lock等待(一)
客户的11.2.0.2 RAC for Linux X86-64环境的数据库在登录时,发现出现长时间等待。 这一篇描述问题的现象的诊断。 出问题的时候我正好在客户现场,于是当时诊断了一下。 客户反映,问题发生在一个用户上,使用这个用户登录需要等待很长时间,而使用其他的用户登录则不存在问题。 首先检查了DBA_PROFILES,确认和密码以及登录有关的PROFILE是否存在限制,当前数据库已经都设置为UNLIMITED,那么问题应该和PROFILE无关。 检查出现问题的用户,也未发现任何特别之处。 在sqlplus上使用这个用户登录,经历了将近10秒左右的等待,终于成功登录。同时检查到会话当时出现library cache lock等待事件。 当再次尝试重现问题时,却已发现问题无法重现了,现在即使使用刚才的问题用户,也可以很快登录成功,并不会出现明显的登录等待。莫非一次成功的登录,就可以解决这个问题。 不过很快,问题再次出现,为了检查会话执行的具体操作,对这个问题用户创建了一个登录触发器,在登录触发器中设置会话的TRACE: SQL> CREATE OR REPLACE TRIGGER T_AFTER_LOGON AFTER LOGON ON DATABASE 2 BEGIN 3 IF USER = ‘GJT’ THEN 4 DBMS_SESSION.SESSION_TRACE_ENABLE(TRUE, TRUE); 5 END IF; 6 … Continue reading
数据库升级导致ORA-918错误
客户的数据库从10.2.0.1升级到10.2.0.5后,出现了ORA-918错误,不过导致错误出现的原因并不是升级碰到了BUG,而是升级解决了BUG。 在Oracle 10.2.0.5中,解决了一个Bug 5368296 ANSI join SQL may not report ORA-918 for ambiguous column,结果原本客户受这个bug影响而没有报错的SQL语句,在升级之后开始大面积报错。 而解决办法除了修改SQL语句外,只有回退一个办法,Oracle显然不会为了重现一个bug而提供什么解决方案。当然这个问题的避免应该通过前期的测试来避免,不过这里还是关注一下这个bug。 在如果使用标准查询写法,当关联表的个数超过2个,且表都包含相同的列名,那么在查询的时候如果不指定这个列名的属主,是不会报错的。 SQL*Plus: Release 10.2.0.3.0 – Production ON Tue Nov 8 15:51:41 2011 Copyright (c) 1982, 2006, Oracle. ALL Rights Reserved. Connected TO: Oracle DATABASE 10g … Continue reading
ORA-600(2037)错误
最近已经碰到多起客户数据库无法打开的情况,这就是其中一次。 这是一个10201 for Windows 64bit数据库,在一次掉电后,数据库无法启动,在后台告警日志中出现下列的错误: Mon Oct 31 00:00:28 2011 ALTER DATABASE OPEN Mon Oct 31 00:00:28 2011 Beginning crash recovery OF 1 threads parallel recovery started WITH 16 processes Mon Oct 31 00:00:28 2011 Started redo scan Mon Oct … Continue reading
Posted in BUG
Tagged 2037, DISTRIBUTE TRANSACTION, IMU, kcbs_dump_adv_state, ORA-600, ORA-7445
Leave a comment
ORA-27300 和skgpspawn3错误
以前碰到过类似的ORA-27300系列错误,问题都是和系统上错误有关,这次的问题也不例外。 详细错误信息如下: Tue May 17 22:01:04 2011 Process startup failed, error stack: Tue May 17 22:01:04 2011 Errors IN file /home/oracle/admin/ARIC/bdump/aric_psp0_866.trc: ORA-27300: OS system dependent operation:fork failed WITH STATUS: 11 ORA-27301: OS failure message: Resource temporarily unavailable ORA-27302: failure occurred … Continue reading
ORA-600(kghstack_underflow_internal_3)错误
客户的数据库环境中出现ORA-600(kghstack_underflow_internal_3)错误。 详细错误信息为: Errors IN file /home/oracle/admin/db1/bdump/db1_dw05_18423.trc: ORA-00600: internal error code, arguments: [kghstack_underflow_internal_3], [0xFFFFFD7FFB6D5FC0], [rpi ROLE SPACE], [], [], [], [], [] ORA-19502: WRITE error ON file "/oradata03/dmp /exp05.20100916.dmp", blockno 11292695 (blocksize=4096) ORA-27063: NUMBER OF bytes READ/written IS incorrect Solaris-AMD64 Error: … Continue reading
ORA-600(kcrrupirfs.20)错误
在客户的数据库告警日志中发现这个错误。 错误信息如下: Thu Sep 29 14:29:26 2011 ALTER DATABASE force logging Thu Sep 29 14:29:26 2011 ALTER DATABASE FORCE LOGGING command IS waiting FOR existingdirect writes TO finish. This may take a long TIME. Completed: ALTER DATABASE force logging LAST_CHECK … Continue reading
Posted in BUG
Tagged DG_CONFIG, kcrrupirfs.20, LOG_ARCHIVE_CONFIG, LOG_ARCHIVE_DEST_N, LOG_ARCHIVE_DEST_STATE_N, ORA-600
Leave a comment